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The UPDATE statement conflicted with the FOREIGN KEY constraint "FK_gen_CompClaim_gen_AdminWorkersCompPolicy".

Application Scope: PEO

Problem

During a loss runs import the import log contains a generic "A business logic error was encountered for line...check the exception log ..."


Cause

The Comp Claim system in ClientSpace includes a lot of validation on information necessary to complete claim logging - one of these data items is the associated Workers' Comp Policy.  Because this needs to be validated, there is a rule that is called by the comp policy import pre-process called "HE_VerifyCompPolicyIsLocated" - if you do not enable this rule on the Imports pipeline, the system allows the comp claim dataform save to happen without a verified fkAdminWorkersCompPolicyID and so the foreign key relationship that is expected later in the save process does not exist.

Solution

If you are importing claim information you must enable the "HE_VerifyCompPolicyIsLocated" rule on the Imports pipeline.  This will unfortunately cause the imported records without a vaild fkAdminWorkersCompPolicyID to fail.


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NOTICE: You are in the old ClientSpace Help system. Please link to the new ClientSpace Help here https://extranet.clientspace.net/helpdoc/home/ClientSpace.htm