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Payroll Statistics Getting Re-generated Causing Duplicate Statistics For PayPeriods

Application Scope: PEO

Problem

When reviewing Client payroll statistics information, you find the PayPeriod amounts are double, triple or even more times greater than they should be.

Cause

Missing data fields on the Voucher import records, or mis-configured Import Configs cause the fkPayrollStatisticsID to not get updated, which in turn causes dupe Payroll Statistics records to be produced.

Solution

The process that generates the Payroll Statistics records and updates the vouchers uses many concurrent Voucher record fields to tie these records together - these fields include Voucher.State, Voucher.CompCode,, Voucher.STARTDATE,  Voucher.ENDDATE, Voucher.PAYDATE, AND Voucher.PAYCYCLE.  If any of these fields are missing either from the Import Config, or the Voucher record that is being produced from the payroll system, the Voucher updates will fail.  The following steps will help to determine the cause, and associated resolution for the issue.

 

  1.  Go to System Admin  | Imports | Manage Import. and examine the Import Configuration for the Voucher files, make sure that each of the fields: Voucher.State, Voucher.CompCode,, Voucher.STARTDATE,  Voucher.ENDDATE, Voucher.PAYDATE, AND Voucher.PAYCYCLE, are in the configuration.  Make note of the appropriate field name from the voucher file being produced by the payroll system.
  2. If any of these fields are missing, update the Import Config to include them by first showing inactive fields, and re-activating the field for import.  If the field is missing, add it to the import configuration.
  3. If all of the fields appear on the import configuration, the problem most likely is in the imported file itself.
  4. Check the Voucher file by going to System Admin  | Imports | Manage Import.
  5. Open the record in question by double clicking in the list or highlighting the record and selecting "Details"
  6. Choose 'View File' and look for each of the above fields, insure the column names match the import configuration and that the columns hold data.  If they do not, correct the issue.
  7. Once you are sure the fields are properly named, populated and configured for import, and can see the fields being filled on the voucher records, create an Extranet case to have the duplicate Payroll Statistics records removed from your system, and the newly generated records synchronized with the associated voucher records.

Import help

 If you are unable to determine the cause, or unable to re-configure your imports, contact your account manager, or NetWise support for help.


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NOTICE: You are in the old ClientSpace Help system. Please link to the new ClientSpace Help here https://extranet.clientspace.net/helpdoc/home/ClientSpace.htm