NOTICE: You are in the old ClientSpace Help system. Please link to the new ClientSpace Help here https://extranet.clientspace.net/helpdoc/home/ClientSpace.htm

Terminated User Still Appears In Dropdown Lists

Application Scope: CORE

Problem

You have an ex-employee who has been terminated, their ClientSpace account de-activated, but the user name still appears in dropdpown lists such as on the Client Team dataform.

Cause

Inactive user is still a Role Member for the role associated with the list.

Solution

Clean up user roles

User Roles - Step by step

 There are two ways to cleanup user roles - removing users from the role and removing roles from the user.

CASE One  - Removing the user from the Role:

  1. Find out which role is associated with the lookup field (dropdown) that you need to fix by going to System Admin | Advanced | Dataforms| Form Fields  the role will be represented by the alphanumeric string stored in the "Related Fields" field.
  2. Copy the Info in the Related Fields area and go to System Admin | Security | Roles and find the Role ID that was stored in "Related Fields"
  3. Open the record by clicking Edit or double clicking the row.
  4. Click on the Users Tab
  5. Check the "Show Inactive" checkbox and search.
  6. You should now be able to highlight and delete the user name from the role list


CASE Two - Removing the Roles from the User:

  1. Open the user profile in question by going to System Admin | Users | ~User Profile~ |Roles
  2. Select each of the Roles on this tab and delete them.
  3. Save the record.


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NOTICE: You are in the old ClientSpace Help system. Please link to the new ClientSpace Help here https://extranet.clientspace.net/helpdoc/home/ClientSpace.htm