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Workflow Does Not Always Work Appropriately

Application Scope: CORE

Problem

Automated business rules can be used to process workflow and sometimes do not work as expected.

Cause

Business Rule trigger conditions are not being adequately met in the expected order, causing rules to fire prematurely.

Solution

Understand the workflow involved and review the ordering of rule firing.  Business rules fire on save and always as follows:

  • Hard Errors in their listed order - then
  • Soft Errors in their listed order - and finally
  • Business logic rules in their listed order.

If a hard error is preventing a trigger condition for a business logic rule, or business logic rules are ordered such that trigger conditions are not met, workflow may work, but only intermittently.  If you have questions about the design of your workflow, or need help with this contact your customer success manager.



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